Caveats:
- trunking interface needed.
- ip routing needs to be enabled
on switches
- fc-tunnel needs to be enabled.
- vsan interface in same subnet in all three switches.
( participating switches)
Switch 1: (intermediate switch).
fc-tunnel enable
interface vsan100
ip address 10.1.1.75 255.255.255.0
no shutdown
ip routing
-----
SWitch II : ( rspan desitnation)
fc-tunnel enable
fc-tunnel tunnel-id-map 100 interface fc1/12
interface fc1/12
switchport mode SD
switchport speed 2000
connect DS_PAA here
interface vsan100
ip address 10.1.1.81 255.255.255.0
no shutdown
ip routing
Switch III: Rspan Source
fc-tunnel enable
interface fc-tunnel 100
destination 10.1.1.81
source 10.1.1.82
explicit-path rspan
no shutdown
fc-tunnel explicit-path rspan
next-address 10.1.1.75 strict
interface vsan100
ip address 10.1.1.82 255.255.255.0
no shutdown
ip routing
interface fc1/8^M
switchport mode ST
switchport speed 2000
rspan-tunnel interface fc-tunnel 100
no shut
----
span session 1^M
destination interface fc-tunnel 100
source interface fc1/10 rx
source interface fc1/10 tx
----
Testing:
show int fc-tunnel 100 ( it should be up, if
it wating for RESV, it means either path
is not reachabled, fspf cost is messed up
( if up and down cost for specific path is
different on vsan 100, or ST is not up or
SD is not configured ).
fc-tunnel 100 is up^M
Dest IP Addr: 10.1.1.81 Tunnel ID: 100^M
Source IP Addr: 10.1.1.82 LSP ID: 1^M
Explicit Path Name: rspan^M
Outgoing interface: port-channel 2^M
Outgoing Label(s) to Insert: 10008:0:1:ff'h ^M
Record Routes:^M
10.1.1.75 ^M
10.1.1.81 ^M
^M
Saturday, April 12, 2008
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment